Tori-Santa 2019
Original Post
Old servers vs New servers, and different versions of Toribash
If you can't see any rooms, or otherwise play toribash, and this happened recently:
Make sure that you are running the newest version of toribash. At the time of this writing, those versions are 3.94 for windows, and 3.93 for OSX. This is because the servers were moved, and the old servers are hardcoded in the old clients.

Two things just happened:

1. Old Toribash servers have been shut down, rendering all toribash versions older than 3.94 useless
2. Vox made a patch to make pre-3.94 versions useful again, by making old clients connect to new servers.

Basically, a lot of people are unable to play with up to date versions, for a variety of reasons. With this patch, you can patch the client of your choice, and play on the new servers.
Lastly you may also need the servers text file below for versions before 3.5, this should replace the servers text file in your installed Toribash folder.

So without further ado:
Click here to download the latest version of Toribash.
Click here to download the patch
Click here to get the server list you will need to make 3.32 and older to work.
Click here to get the client of your choice

NB: This patch only works with windows clients. But a Mac version is under development

Confirmed working with versions:
3.01 (Requires servers.txt as provided above, not the patch.)
3.32 (Requires servers.txt as provided above, not the patch.)
3.5
3.56
3.69
3.71
3.85
3.86
3.9
3.91
Last edited by Vox; Dec 9, 2011 at 01:24 PM. Reason: Patch updated to work on older versions.
http://www.jarmund.net
- For all your feline oriented pornography -
Now asbestos free!
Ooooh great, i had some problems with the new version, thanks alot for this work.
Last edited by Master5000; Dec 9, 2011 at 03:31 AM.
Oldschool / M5k / Contact KiTFoX
I'm back
Awesome, will test it out later tonight.
~Rainbow Belt|[Tint]|Rank 32~
\:D/ RAINBOW PANDAAAAA \:D/
~GameMaster|BISH|GameGrad|ORMO|ToriPrime L-Mod~

ZinxGlowToastBondyLoxSwyneErth
[Bsns][Fr3styL][Colon3][One][SyN][Rvng]

Toribash World Championship 2011 Runner Up

<AlphasoniK> Kristis: What the fuck is wrong with you, rainbow loving panda freak.
Seriously, try to piss standing up for a change. No life girly pants dimwit.

yup, old servers have been killed now.. happy patching/upgrading
Last edited by Jarmund; Dec 9, 2011 at 04:46 AM.
http://www.jarmund.net
- For all your feline oriented pornography -
Now asbestos free!
Please message me if you have a problem with the hotfix, if you don't know how to use it just plonk the file into your Toribash folder and run it, running it multiple times should have no effect.

If you would like the source to the hotfix you should also message me. If you have a mac you should also message me, I need a tester.

[EDIT]No longer need a tested, need a compiler >.>
Last edited by Vox; Dec 15, 2011 at 11:50 PM.
Tried it on both 3.85 and 3.91, it's working on both of them quite well. Great job so far!
<&Erth> fagm <&Erth> duck <&Erth> *fuck
Fagm duck fuck everyone.

quick question not to be annoying or anything but what happend to version 3.92 and 3.93??!!
Lol I know Your jelly yeah........
Originally Posted by jcmert View Post
quick question not to be annoying or anything but what happend to version 3.92 and 3.93??!!

3.93 was immediately patched to 3.94, 3.92 was probably never released.
Originally Posted by jcmert View Post
quick question not to be annoying or anything but what happend to version 3.92 and 3.93??!!

Yep, pretty much what VOX said. 3.92 was never released. 3.93 was broken for windows, and was replaced by 3.94 after 5 minutes or so, hence why there are different "newest version" for OSX and Windows at the moment.
http://www.jarmund.net
- For all your feline oriented pornography -
Now asbestos free!