Ranking
Original Post
Old servers vs New servers, and different versions of Toribash
If you can't see any rooms, or otherwise play toribash, and this happened recently:
Make sure that you are running the newest version of toribash. At the time of this writing, those versions are 3.94 for windows, and 3.93 for OSX. This is because the servers were moved, and the old servers are hardcoded in the old clients.

Two things just happened:

1. Old Toribash servers have been shut down, rendering all toribash versions older than 3.94 useless
2. Vox made a patch to make pre-3.94 versions useful again, by making old clients connect to new servers.

Basically, a lot of people are unable to play with up to date versions, for a variety of reasons. With this patch, you can patch the client of your choice, and play on the new servers.
Lastly you may also need the servers text file below for versions before 3.5, this should replace the servers text file in your installed Toribash folder.

So without further ado:
Click here to download the latest version of Toribash.
Click here to download the patch
Click here to get the server list you will need to make 3.32 and older to work.
Click here to get the client of your choice

NB: This patch only works with windows clients. But a Mac version is under development

Confirmed working with versions:
3.01 (Requires servers.txt as provided above, not the patch.)
3.32 (Requires servers.txt as provided above, not the patch.)
3.5
3.56
3.69
3.71
3.85
3.86
3.9
3.91
Last edited by Vox; Dec 9, 2011 at 02:24 PM. Reason: Patch updated to work on older versions.
Originally Posted by Kickass View Post
Im trying to use it with 3.86 and its not working, any suggestions/help? I cant update either so dont even go there.

You need to put ServerHotfix.exe into the Toribash-3.86/ folder then run it, what have you tried so far and what does the executable print out when running?

Originally Posted by tricerafi View Post
is it work for MAC too?

Not yet, we are working on a MAC version.

Originally Posted by 00Plastic View Post
Version 3.93 isnt working for me. Im trying to play on a 10.4.11 OS X MacBook pro. The program just wont start. Im clicking on the toribash.app icon but nothing happens...
Any hope for a patch in the near future?
thx in advance, because u ppl are doing a really great job with that game and stuff!

Mac OSX 10.5 and older are not supported any-more due to apple being annoying about backwards compatibility, I will try to get a version of the patch compiled that works for old OSX versions as well so that you can still play.
Originally Posted by Vox View Post
You need to put ServerHotfix.exe into the Toribash-3.86/ folder then run it, what have you tried so far and what does the executable print out when running?


Yeah i did that, saved it to my desktop then just dragged it into the folder. I run toribash and go to multiplayer and theres no list.

And what do u mean by "...what does the executable print out when running?"
[RelaxAll]Nikelaos:Kickass is chained to this clan with indestructible shackles, his balls are also superglued to the chair.
[SIGPIC][/SIGPIC]

Run ServerHotfix.exe and it will pop up a dialogue, it will print out some text then say "press any key to exit", can you tell me what it prints out?
What do i run it with? I open it with like notepad and a theres a bunch of weird symbols n stuff.

Sorry, keep in mind my computer is royally hooped.
[RelaxAll]Nikelaos:Kickass is chained to this clan with indestructible shackles, his balls are also superglued to the chair.
[SIGPIC][/SIGPIC]

It's an executable, you run it. Double click it. You know how .exe's work right?
is it just me or the servers are offline? cause i dont see any when i click multiplayer, and i could see them like 5 hours ago...

edit: my post count is The Answer to life, space and everything else.
Originally Posted by Bl4ckDr4g0N View Post
is it just me or the servers are offline? cause i dont see any when i click multiplayer, and i could see them like 5 hours ago...

edit: my post count is The Answer to life, space and everything else.

The server list is working fine and the servers are online, what version are you running and are you using the patch?
i got 3.94.. wait even though i have the latest version i still have to install the patch? that makes sense, thanks.
Originally Posted by Vox View Post
You need to put ServerHotfix.exe into the Toribash-3.86/ folder then run it, what have you tried so far and what does the executable print out when running?



Not yet, we are working on a MAC version.



Mac OSX 10.5 and older are not supported any-more due to apple being annoying about backwards compatibility, I will try to get a version of the patch compiled that works for old OSX versions as well so that you can still play.

please be fast i really need it
"0h no" -Trice
A.K.A Tricerafi || Thanks Papa Donut, bless you
Originally Posted by Jarmund View Post
yup, old servers have been killed now.. happy patching/upgrading

ohh get thta's why thanks now i dl'ed 3,94